• Ешқандай Нәтиже Табылған Жоқ

Моделирование систем телекоммуникаций

N/A
N/A
Protected

Academic year: 2023

Share "Моделирование систем телекоммуникаций"

Copied!
57
0
0

Толық мәтін

(1)

1

МОДЕЛИРОВАНИЕ СИСТЕМ ТЕЛЕКОММУНИКАЦИЙ Методические указания к выполнению лабораторных работ

для студентов специальности

5В071900 – Радиотехника, электроника и телекоммуникации

Алматы 2018

АЛМАТИНСКИЙ УНИВЕРСИТЕТ ЭНЕРГЕТИКИ И СВЯЗИ

Кафедра

телекоммуникационных сетей и систем

(2)

2

СОСТАВИТЕЛИ: Туманбаева К.Х., Лещинская Э.М. Моделирование систем телекоммуникаций. Методические указания к выполнению лабораторных работ для студентов специальности 5В071900 – Радиотехника, электроника и телекоммуникации. - Алматы: АУЭС, 2018.- 56с.

Методические указания содержат задания и рекомендации для выполнения лабораторных работ по дисциплине «Моделирование систем телекоммуникаций». Выполнение работ позволит овладеть методами имитационного моделирования для решения задач анализа и синтеза в области телекоммуникаций, приобрести навыки работы со специализированной системой имитационного моделирования GPSS World.

Ил.23, табл.23, библиогр.- 10 назв.

Рецензент: Мусапирова Г.Д., к.т.н., доцент кафедры «IT – инжиниринг».

Печатается по плану издания некоммерческого акционерного общества

«Алматинский университет энергетики и связи» на 2018 г.

© НАО «Алматинский университет энергетики и связи», 2018 г.

(3)

3 Введение

Целью лабораторных работ является ознакомление студентов с основными этапами построения моделей, вопросами имитационного моделирования, получение навыков исследования систем телекоммуникаций с помощью одного из языков моделирования — GPSS World.

При имитационном моделировании на компьютере имитируется работа проектируемой системы. Математическая модель при этом реализуется в виде программы для компьютера. В результате экспериментов на компьютере собирается статистика, обрабатывается и выдается необходимая информация.

Задачей лабораторных работ являются овладение студентами методами имитационного моделирования систем телекоммуникаций, приобретение навыков работы со специализированными системами имитационного моделирования, такими как GPSS World.

Учебным планом для данной дисциплины отводится 3 кредита.

(4)

4

1 Лабораторная работа №1. Формирование последовательности случайных дискретных чисел по заданному закону распределения

Цель работы: разработка программ на алгоритмическом языке (Паскаль), формирующих последовательность случайных дискретных чисел по заданному закону распределения.

1.1 Подготовка к работе

1.1.1 Изучить и освоить теоретический материал по моделированию последовательности случайных дискретных чисел по заданному закону распределения.

1.1.2 Изучить операторы и команды, необходимые для имитационного моделирования на алгоритмическом языке Паскаль.

1.2 Задание к работе

1.2.1 Разработать программу на алгоритмическом языке Паскаль, формирующую N последовательность чисел, распределенных по равномерному закону в промежутке (a,b).

1.2.2 Разработать программу на алгоритмическом языке Паскаль, формирующую последовательность N чисел, распределенных по показательному закону с интенсивностью λ.

1.2.3 Разработать программу на алгоритмическом языке Паскаль, формирующую последовательность К чисел, распределенных по нормальному закону с математическим ожиданием М и среднеквадратическим отклонением σ.

1.2.4 Подготовить отчет о выполненной работе, где представить свои программы на языке Паскаль, результаты моделирования и анализ полученных данных.

1.3 Варианты заданий

1.3.1 Варианты и данные к первому заданию Т а б л и ц а 1.1

Номер варианта

N a b

1 10 0 12

2 9 2 15

3 3 1 16

4 5 3 18

5 8 7 12

(5)

5

1.3.2 Варианты и данные ко второму заданию Т а б л и ц а 1.2

Номер

варианта N λ

1 10 1,1

2 9 1,2

3 11 1,3

4 5 1,4

5 8 1,5

6 7 1,6

7 6 1,7

8 9 1,8

9 8 1,9

10 7 2,0

11 11 2,1

12 6 2,2

13 7 2,3

14 8 2,4

15 9 2,5

1.3.3 Варианты и данные к третьему заданию Т а б л и ц а 1.3

Номер варианта

K M σ

1 7 10 1,2

2 8 9 1,3

3 9 8 1,5

4 10 7 2,2

5 11 11 3,3

6 10 12 2,6

6 7 5 10

7 6 3 16

8 9 0 10

9 3 2 5

10 7 1 13

11 11 2 14

12 6 7 10

13 5 1 8

14 3 2 9

15 4 1 7

(6)

6

7 9 10 2,1

8 7 9 1,8

9 6 8 1,7

10 5 7 1,6

11 10 6 1,5

12 9 7 1,4

13 5 8 2,0

14 6 9 1,9

15 7 10 2,5

1.4 Контрольные вопросы

1. Какие действия нужно выполнить, чтобы получить последовательность случайных чисел, подчиняющихся заданному закону распределения?

2. С помощью какой стандартной функции алгоритмичекого языка Паскаль можно получить последовательность случайных чисел, распределенных по равномерному закону в промежутке (0, 1)?

3. Как отобразить на графике кривые, соответствующие равномерному, нормальному и экспоненциальному законам распределения случайных величин?

4. Приведите блок-схему программы получения последовательности случайных чисел, распределенных по нормальному закону распределения.

5. Как вывести на печать полученные случайные числа с заданной точностью, например, 2 знака после запятой?

2 Лабораторная работа №2. Работа с интерфейсом системы GPSS World

Цель работы: изучение возможностей главного меню системы имитационного моделирования GPSS World, приобретение навыков работы с системой в интерактивном режиме.

2.1 Подготовка к работе

2.1.1 Изучить и освоить понятия имитационного моделирования, систем массового обслуживания (материал для подготовки к лабораторной работе).

2.1.2 Изучить пункты главного меню системы GPSS World.

2.2 Задание к работе

2.2.3 Разработать модель одноканальной СМО на GPSS World, в которой промежутки времени между поступлениями транзактов равномерно

(7)

7

распределены в промежутке (А±В), время обслуживания транзакта равномерно распределено в промежутке (С±D). Число транзактов в модели – N. Назовем эту модель Модель 1.

2.2.4 Разработать модель одноканальной СМО на GPSS World, в которой промежутки времени между поступлениями транзактов равномерно распределены в промежутке (А±В), время обслуживания транзакта равномерно распределено в промежутке (С±D). Время моделирования равно числу часов, равных Вашему варианту. Назовем эту модель как Модель 2.

2.3 Порядок работы

2.3.1 Запустить GPSS World.

2.3.2 Ознакомиться с пунктами главного меню. Изучить команды ниспадающих меню, изучить их возможности.

2.3.3 Ввести разработанные модели в систему GPSS World, запустить процесс моделирования и получить результаты. Параметры моделей взять соответственно варианту по таблице 2.1.

2.3.4 Заполнить таблицу 2.2 на основании полученных результатов моделирования.

2.3.5 Подготовить отчет о выполненной лабораторной работе, где представить 2 модели, результаты моделирования и анализ полученных данных.

2.4 Варианты заданий Т а б л и ц а 2.1

Номер варианта

N A

(мин.)

B (мин.)

C (мин.)

D (мин.)

1 25 20 2 15 3

2 20 21 3 16 5

3 21 22 5 17 6

4 22 23 6 18 4

5 23 24 7 19 3

6 26 25 8 20 6

7 27 26 9 21 7

8 31 27 10 22 8

9 35 28 11 23 9

10 39 29 12 24 2

11 42 30 7 25 3

12 43 31 8 26 4

13 44 32 9 27 5

(8)

8

14 45 33 10 28 6

15 51 34 11 29 7

Т а б л и ц а 2.2 - Сравнительный анализ моделей

Показатели Модель 1 Модель 2

1.Среднее время занятия устройства 2.Коэффициент использования устройства

3. Среднее время пребывания в очереди 4. Средняя длина очереди

5.Продолжительность моделирования

2.5 Методические указания к выполнению лабораторной работы Чтобы запустить программу, дважды щелкните мышью по файлу GPSSW.exe в каталоге, в котором была установлена система. Появится главное окно системы GPSS World.

. Рисунок 2.1 – Главное окно системы GPSS World

В первой строке (строке заголовка) главного окна указано название окна- GPSS World. Во второй строке располагаются пункты главного меню, в третьей – стандартная панель инструментов. Нижняя строка главного окна – строка состояния системы, в которой дается краткое описание выделенной команды.

(9)

9

Главное меню обеспечивает доступ ко всем средствам системы GPSS World. По своей сути главное меню является основным управляющим центром этой системы.

Рассмотрим пункты главного меню.

Меню File

Пункт File служит для работы с файлами документов. Файлы имитационных моделей в системе GPSS World записываются в окне Model и сохраняются с расширением .gps, текстовые файлы записываются в окне Text File и сохраняются с расширением .txt. Они имеют текстовый формат, поэтому их легко прочитать и модифицировать при помощи текстового редактора.

Файлы могут содержать и результаты проведенного моделирования.

Эти файлы создаются после сохранения содержимого окна REPORT (отчет).

При этом файл будет иметь расширение .gpr. Кроме того, можно сохранить сообщения, появляющиеся в процессе моделирования систем. Эти сообщения, выводимые в окне JOURNAL, можно сохранить в файле с расширением .sim.

Выпадающее меню пункта File содержит следующий набор пунктов:

New…

Open…

Close Save Save As…

Print…

Internet Recent File Exit

При выборе пункта New появляется диалоговое окно Новый документ. С помощью пункта Model можно создать новый файл для моделирования и текстовый файл с помощью пункта Text File. После выбора типа файла появится соответствующее окно: для ввода моделируемой системы – Untitled Model 1 (Без названия модель 1) – или для создания текстового файла – Untitled Text File 1 (Без названия текстовый файл 1).

Меню Edit.

Выбор пункта Edit вызывает ниспадающее меню редактирования.

Кроме известных пунктов Undo (отменить), Cut (вырезать), Copy (копировать), Paste (вставить), оно содержит следующие:

Expression Window… (окно выражения) вызывает диалоговое окно Edit Expression Window;

Plot Window…(окно графика) вызывает диалоговое окно Edit Plot Window;

Insert GPSS Blocks…(вставить блоки GPSS) вызывает диалоговое окно, в котором можно щелчком мыши выбрать нужный блок GPSS (рисунок 2.2).

(10)

10

Рисунок 2.2 – Диалоговое окно Insert GPSS Blocks

Как видим из рисунка 2, в диалоговое окно входят 53 блока. Если щелкнуть по любому из них, то появится соответствующее диалоговое окно.

Допустим, вы щелкнули по блоку GENERATE, на экране появится шаблон блока для ввода необходимой информации (рисунок 2.3).

Рисунок 2.3 – Шаблон блока GENERATE

Insert Experiment (Вставить эксперимент) вызывает всплывающее меню для выбора соответствующего эксперимента.

(11)

11

Settings … (Установки) вызывает диалоговое окно, в котором можно определить те или иные установки системы.

Меню Search.

Выбор пункта Search (поиск) позволяет осуществить такие действия, как нахождение и исправление ошибки, переход к нужной строке, установка необходимых закладок, установление и удаление меток в тексте программы, выделение текста от курсора до установленной метки. Все указанные действия можно выполнить с помощью команд ниспадающего меню, которое появляется после выбора данного пункта.

Меню View.

Выбор пункта View главного меню позволяет открывать различные окна, панели или меню:

1) Notices (Сообщения) вызывает окно Notices.

2) Toolbar(Панель инструментов).

3) Entity Details(Детальное представление элемента).

4) Simulation Clock(Часы моделирования).

Меню Command.

Выбор пункта Command главного меню вызывает ниспадающее меню следующих команд:

1) Create Simulation (Создать выполняемую модель) вызывает

транслятор и выполняет трансляцию исходной модели с фиксацией даты и времени начала и окончания трансляции.

2) Retranslate (Перетранслировать) обеспечивает перетранслирование модели.

3) Repeat Last Command (Повторить последнюю команду).

4) CONDUCT(Управление) дает возможность проведения эксперимента.

5) START (Пуск) обеспечивает запуск оттранслированной программы.

6) STEP1 (Шаг 1) обеспечивает пошаговое выполнение программы.

7) HALT (Останов) прерывает процесс моделирования.

8) CONTINUE (Продолжить) обеспечивает продолжение моделирования.

9) CLEAR (Очистить) возвращает моделирование в первоначальное состояние.

10) RESET (Сброс) осуществляет сброс статистики в начальное состояние.

11) SHOW …(Показать) показывает искомые параметры.

12) Custom … (Пользователь) обеспечивает возможность ввода команд управления пользователем.

Меню Window.

Система GPSS World позволяет эффективно работать с несколькими окнами. Под каждую модель отводится отдельное окно. Одно из них является активным, то, с которым пользователь работает. Система также позволяет работать с несколькими окнами одновременно. Выбор

(12)

12

пункта Window главного меню позволяет управлять работой с несколькими окнами. Наряду с известными командами (Cascade, Tile), позволяющими расположить окна на рабочем столе в нужном виде, меню предлагает следующие команды:

1) Simulation Window (Окно моделирования) вызывает всплывающее меню, которое содержит команды для вызова нужных окон.

2) Simulation Snapshot (Снимок моделирования) вызывает всплывающее меню со списком окон различных снимков моделирования и окон, открытых в данный момент.

Меню Help.

Выбор пункта Help (Справка) главного меню открывает меню:

1) Help Topics (Вызов справки) вызывает справочную систему.

2) About GPSS World …(О системе GPSS World) обеспечивает дополнительной информацией по системе.

2.6 Контрольные вопросы

1. В каком блоке генерируются транзакты?

2. Какая случайная величина распределена по равномерному закону в блоке GENERATE?

3. Какие показатели работы устройства можно увидеть в отчете REPORT?

4. Какие данные об очереди можно увидеть в отчете REPORT?

5. Как можно организовать время работы модели?

3 Лабораторная работа №3. Моделирование времени обслуживания в одноканальной СМО

Цель работы: изучить и освоить способы задания вероятностных законов распределения промежутков между моментами поступления транзактов и времени обслуживания.

3.1 Подготовка к работе

3.1.1 Изучить и освоить теоретический материал по использованию библиотечных процедур для задания различных законов распределения.

3.1.2 Изучить блоки и команды, представленные в базовой модели.

3.1.3 Изучить способы представления различных законов распределения в блоках GENERATE и ADVANCE.

3.2 Задание к работе

Разработать модель трех систем массового обслуживания (M/D/1, M/M/1 и M/G/1) с параметрами, соответствующими вашему варианту.

(13)

13

Провести процесс моделирования, получить результаты, заполнить таблицу 1.1 данными из полученного отчета, получить результаты в виде гистограмм.

3.3 Порядок выполнения работы

3.3.1 Получить задание и вариант работы у преподавателя.

3.3.2 Осуществить ввод операторов базовой модели, отладить и запустить программу, результаты сравнить с таблицей 3.2.

3.3.3 Ввести изменения в базовую модель в соответствии со своим вариантом.

3.3.4 Проделать по шагам для своей модели пункт 3.3.1

3.3.5 Получить статистику формирования очередей для каждого типа обслуживания (постоянное, экспоненциальное и эрланговское), заполнить таблицу 3.1 полученными данными.

3.3.6 Получить результат моделирования в виде отчета, гистограмм и оперативного экрана.

3.3.7 Подготовить отчет о выполненной работе, где представить свою модель, результаты моделирования и анализ полученных данных.

3.4 Варианты лабораторной работы Т а б л и ц а 3.1

№ варианта

Среднее время обслуживания (сек.) Время

обслуживания постоянно

Время

распределено по экспоненц. закону

Время

распределено по эрланговск. закону

1 2,1 2,5 1,1

2 2,2 2,6 1,2

3 2,3 2,7 1,3

4 2,4 2,8 1,4

5 2,5 2,9 1,5

6 2,6 3,1 1,6

7 2,7 3,2 1,7

8 2,8 3,3 1,8

9 2,9 3,4 1,9

10 3,1 3,5 2,0

11 3,2 3,6 2,1

12 3,3 3,7 2,2

13 3,4 3,8 2,3

14 3,5 3,9 2,4

15 3,6 4,0 1,0

(14)

14

3.5 Методические указания к выполнению лабораторной работы

Введите листинг базовой модели в систему GPSS World Transit TABLE M1,250,250,20

Number TABLE Q$Expon,0,1,20

Qconstant QTABLE Constant,200,200,20 Qexpon QTABLE Expon,200,200,20 Qerlang QTABLE Erlang,200,200,20

*******************************************************************

GENERATE (Exponential (1,0,500) ) QUEUE Constant

SEIZE Facility1 ADVANCE 300 RELEASE Facility1

DEPART Constant TERMINATE

*******************************************************************

GENERATE (Exponential(1,0,500) ) QUEUE Expon

SEIZE Facility2

ADVANCE (Exponential (1,0,300)) RELEASE Facility2

DEPART Expon TABULATE Transit TERMINATE

*******************************************************************

GENERATE (Exponential(1,0,500)) QUEUE Erlang

SEIZE Facility3

ADVANCE (Exponential (1,0,150)) ADVANCE (Exponential(1,0,150)) RELEASE Facility3

DEPART Erlang TERMINATE

******************************************************************

GENERATE (Exponential(1,0,6000)) TABULATE Number

TERMINATE 1

Программа моделирует один служебный канал, по которому поступают запросы, время поступление которых изменяется по экспоненциальному закону со средним значением 5 секунд (500 тактов). Среднее время обслуживания составляет 3 секунды (300 тактов). Среднее значение коэффициента использования сервера составляет 60%.

(15)

15

Необходимо исследовать 3 режима времени обслуживания:

1) Постоянное время обслуживания.

2) Экспоненциально распределенное время обслуживания.

3) Время обслуживания, распределенное по эрланговскому закону (к=2).

Выполните следующие действия:

1) Запустите процесс моделирования на 500 минут.

2) Получите статистику формирования очередей для каждого типа обслуживания.

Модель состоит из трех сегментов, в которых транзакты имеют соответственно постоянное время обслуживания, время обслуживания, распределенное по экспоненциальному и по эрланговскому законам (K=2).

В последнем дополнительном сегменте транзакты распределены по экспоненциальному закону. Они определяют время моделирования и уменьшают счетчик завершения в среднем один раз каждый модельный час.

После того, как базовая модель будет введена, необходимо создать процесс моделирования. Выберите Command / Create Simulation, затем выберите Command / START. В диалоговом окне замените 1 на 500.

После завершения процесса моделирования будет выведен отчет. Для того чтобы сохранить полученный отчет в виде файла, скопируйте его в текстовый редактор (он вам будет нужен при составлении отчета по лабораторной работе).

Из полученного отчета выберите данные для заполнения таблицы 3.1.

В таблице представлены данные, которые получены при запуске базовой модели. После того как в базовую модель будут внесены изменения в соответствии с вашим вариантом, заполните таблицу 3.2 вашими результатами.

Т а б л и ц а 3.2

Постоянное время

обслуживания

Экспоненциаль- ное время

обслуживания

Эрланговское время

обслуживания Среднее время

пребывания в очереди 526,7 757,5 649,4

Средняя длина очереди 1,05 1,50 1,29

Среднее время ожидания (среднее время

пребывания в очереди за вычетом среднего

времени обслуживания)

226,7 453,5 349,7

Стандартное отклонение времени пребывания в

очереди 287 739,9 595

(16)

16

В отчете по лабораторной работе нужно представить гистограммы Transit, Number, Qconstant, Qexpon, Qerlang.

Для того чтобы получить названные гистограммы необходимо выполнить Window / Simulation Window / Table Window, и выбрать нужную гистограмму, например, QEXPON (рисунок 3.1).

Рисунок 3.1 – Вид окна QEXPON 3.6 Контрольные вопросы

1. С какой целью разработана система символических обозначений СМО Кендалла? В чем предназначение каждого из шести разрядов символики?

2. Чем отличаются системы массового обслуживания вида: M/M/1, M/D/1, M/G/1?

3. Какая из трех исследуемых Вами СМО отличается лучшими показателями качества работы?

4. Как получить гистограмму распределения случайной величины

«Время пребывания в очереди»?

5. С использованием каких системных числовых атрибутов (СЧА) могут быть получены гистограммы распределения случайных величин «Время пребывания в системе», «Текущая длина очереди»?

(17)

17

4 Лабораторная работа №4. Исследование на имитационной модели простой телефонной системы

Цель работы: анализ модели работы АТС и приобретение навыков использования динамических окон системы GPSS World

4.1 Подготовка к работе

4.1.1 Изучить пункты главного меню системы GPSS World, необходимые в работе: меню: Window/Simulation Window.

4.1.2 Изучить блоки и команды необходимые для моделирования многоканального устройства.

4.2 Задание к работе

Разработать модель простой АТС, соответствующую вашему варианту.

Провести процесс моделирования, получить результаты, заполнить таблицу 4.1 (N1, и N2 даны для каждого варианта), определить оптимальное число линий.

Т а б л и ц а 4.1 – Результаты моделирования Число

внешних линий

Число звонков

Текущее время

Коэффициент использования

Средняя длительность звонка

2 N1

2 N2

3 N1

3 N2

4 N1

4 N2

4.3 Порядок выполнения работы

4.3.1 Получить задание и вариант работы у преподавателя.

4.3.2 Разработать модель АТС.

4.3.3 Осуществить ввод операторов модели, отладить программу.

4.3.4 Запустить процесс моделирования при количестве звонков N1, и N2 и числе линий 2, 3 и 4.

4.3.5 Проделать по шагам п. 4.5.2 для своей модели.

4.3.6 Получить статистику формирования загрузки линий связи, статистику длительности завершенных звонков.

4.3.7 Получить результаты моделирования в виде отчета, гистограмм и оперативного экрана.

(18)

18

4.3.8 Подготовить отчет по выполненной работе, где представить свою модель, результаты моделирования и сделать выводы.

4.4 Варианты лабораторной работы Т а б л и ц а 4.2 - Варианты заданий

варианта

N1 N2 Интервалы между

поступлениями звонков (сек.)

Длительность разговора (мин.)

Интервал для повторного звонка (мин.)

1 203 1000 100 ± 40 2 ± 1 3 ± 1

2 205 1005 100 ± 45 2,5 ± 1 3 ± 2

3 210 1010 100 ± 50 3 ± 1 4 ± 1

4 215 1020 100 ± 55 2 ± 1,5 4 ± 2

5 220 1030 100 ± 60 2,5 ± 1,5 4 ± 3

6 225 1040 110 ± 40 3 ± 1,5 5 ± 1

7 230 1050 110 ± 45 4 ± 1 5 ± 2

8 235 1060 110 ± 50 4,5 ± 1 5 ± 3

9 240 1070 110 ± 55 3 ± 2 5 ± 4

10 245 1080 110 ± 60 4 ± 2 5,5 ± 1

11 250 1090 120 ± 30 4,5 ± 2 5,5 ± 2

12 255 1100 120 ± 35 4 ± 1,5 5,5 ± 3

13 260 1110 120 ± 40 4,5 ± 1,5 6 ± 1

14 265 1120 120 ± 45 5 ± 1,5 6 ± 2

15 270 1130 120 ± 50 5 ± 2 6 ± 3 4.5 Методические указания к выполнению лабораторной работы Постановка задачи.

Телефонная система имеет две внешние линии. Внешние звонки поступают каждые 100±60 секунд. Если линия занята, то звонок повторяется через 5±1 минуту до тех пор, пока не будет обслужен. Звонок длится 3±1 минуту. Нужно занести в таблицу распределение времени, необходимого для выполнения успешных звонков. Сколько времени потребуется для завершения 200 звонков?

Листинг базовой программы представлен на рисунке 4.1. Время дано в минутах.

Необходимо создать процесс моделирования. Выберите Command / Create Simulation.

После этого выберите Command / START. В диалоговом окне замените 1 на 200 и нажмите ОК.

Листинг базовой модели:

Sets STORAGE 2

(19)

19

Transit TABLE M1,.5,1,20 ;Транзитное время.

GENERATE 1.667,1 . ;Входящие звонки.

Again GATE SNF Sets,Occupied;Попытка занять линию.

ENTER Sets ;Установление соединения.

ADVANCE 3,1 ;Разговор, длящийся 3±1 минуту.

LEAVE Sets ;Освобождение линии.

TABULATE Transit ;Занесение в таблицу тр. врем.

TERMINATE 1 ;Удаление транзакта.

Occupied ADVANCE 5,1 ;Ожидание в течение 5±1 мин.

TRANSFER ,Again ;Повторная попытка

Процесс моделирования завершится, когда 200 транзактов войдут в блок TERMINATE. Это соответствует 200 завершенным звонкам.

После завершения процесса моделирования GPSS World выводит отчет в файл отчета, заданного по умолчанию.

Этот отчет будет автоматически выведен в окно. Если вы закроете окно, повторно его можно будет открыть с помощью команды главного меню File / Open. Затем в выпадающем списке «Files of type» («Тип файла») выбрать Report (Отчет).

Из значения End Time в стандартном отчете мы видим, что к моменту, когда 200 звонков были завершены, прошло 359.16 минуты. Повторное моделирование благодаря использованию случайных чисел даст немного другие значения.

Таблица с именем Transit дает более детальную информацию о том, сколько времени потребовалось звонящим для совершения звонков. Хотя большинство звонящих уложились меньше чем в 9.5 минут, большое количество звонков заняло больше времени. Возможно, именно в этом будет источник неудовлетворенности потребителя.

Теперь исследуем конечное состояние процесса моделирования, сгенерировавшего стандартный отчет. Если процесс моделирования не был завершен, повторно оттранслируйте модель и запустите ее снова. Если у вас открыто окно «Report» («Отчет»), закройте его.

Воспользуемся окном «Expression» («Выражения») для просмотра некоторых стандартных числовых атрибутов. Во-первых, подтвердим время окончания процесса моделирования. Выберите Window / Simulation Window / Expression Window .

Для ввода значения в пустое поле диалогового окна необходимо поместить указатель мыши в его начало и нажать один раз левую кнопку. Не используйте клавишу [Enter] для перехода от одного поля ввода к другому, так как в этом случае GPSS World решит, что все значения были введены. Для перемещения от поля к полю можно использовать клавишу [Tab]. Теперь в поле «Label» («Метка») диалогового окна наберите Время, а в поле

«Expression» («Выражение») - АС1.

Это позволит нам просмотреть текущее время. Нажмите View (Просмотр) и Memorize (Запомнить).

(20)

20

Если выражение было сохранено, то можно закрыть это окно, позже открыть его снова и восстановить все значения. При сохранении процесса моделирования значения в окне «Expression» («Выражения») сохраняются вместе с ним в том случае, когда они были сохранены ранее. Мы собираемся закрыть это окно и открыть его позже, поэтому просьба сохранить это выражение и все последующие.

Теперь посмотрим на коэффициент использования телефонных линий (в долях от тысячи). В поле «Label» («Метка») замените текущее значение на коэффициент использования. Также замените текущее значение в поле

«Expression» («Выражение») на SR$Sets. Нажмите View (Просмотр) и Memorize (Запомнить).

Наконец, добавим среднее время использования телефонной линии. В поле «Label» («Метка») замените текущее значение на «Сред. длит. Звонка», а в поле «Expression» («Выражение») - на ST$Sets. Нажмите View (Просмотр) и Memorize (Запомнить). Нажмите ОК.

Коэффициент использования выражается в долях от тысячи. Линии используются на 84% от их пропускной способности. И хотя имеется некоторый запас пропускной способности, задержки в очереди могут стать недопустимыми.

Теперь закройте окно «Expression» («Выражения»).

Откроем некоторые графические окна. Выберите Window / Simulation Window / Storages Window .

Рисунок 4.1 – Окно «Памяти»

Это подробный обзор окна «Storages» («Памяти»). Обратите внимание, что загрузка составила 84%. Из минимального и максимального значений использования памяти мы видим, что иногда в процессе моделирования были заняты 0, 1 или 2 линии. Используйте полосу прокрутки в нижней части экрана, чтобы перейти к значениям, о которых мы сейчас говорим. Окно

(21)

21

«Storages» («Памяти») рассматривается в Главе 5 Руководства пользователя по GPSS World.

Если открыть окно «Table» («Таблицы»), то можно увидеть диаграмму длительностей завершенных звонков. Выберите Window / Simulation Window / Table Window (Окно / Окно процесса моделирования / Окно «Таблица»). Так как в этой модели есть только одна таблица, то в выпадающем списке вы сразу увидите TRANSIT. Нажмите ОК.

Удостоверьтесь, что размер вашего окна «Table» («Таблицы») достаточно велик, чтобы правильно отобразить таблицу. Здесь приводится та же информация, что и в стандартном отчете. Как показывает СЧА ST в окне

«Expression» («Выражения»), среднее время разговора равно 3 минутам, однако, как видно из окна «Table» («Таблицы»), среднее время, включая повторные звонки, составляет 14.27 минуты. Звонящие затрачивают слишком много времени на повторные звонки.

Рисунок 4.2 – Вид таблицы TRANSIT

Давайте посмотрим, где находятся транзакты. Выберите Window / Simulation Window / Blocks Window (Окно / Окно процесса моделирования / Окно «Блоки»). Это окно «Blocks» («Блоки»).

Обратите внимание, что 15 человек ждут, чтобы перезвонить.

Посмотрим на историю входов в блоки в столбце «Entry Count» («Количество входов»).

(22)

22

Рисунок 4.3 – Окно «Blocks» («Блоки»), показывающее блок TRANSFER

Обратите внимание на число транзактов, вошедших в блок ADVANCE.

Все они ждали, чтобы перезвонить, т.е. 561. При этом было сделано только 200 звонков. Смотрите на окно «Blocks» («Блоки») и используйте функциональную клавишу [F5], позволяющую сделать один шаг в процессе моделирования. Нажмите ее 15 или 20 раз. Многие звонящие при повторном звонке снова обнаруживают, что все линии заняты и снова должны ждать, чтобы перезвонить.

Вернемся к просмотру процесса моделирования с помощью графических окон. Закройте все открытые окна за исключением окон «Blocks»

(«Блоки»), «Journal» («Журнал») и «Model» («Модель»).

Повторно откроем окно «Expression» («Выражения») со значениями, которые мы сохранили ранее, и добавим номер звонка, который также является номером активного транзакта. Выберите Window / Simulation Window / Expression Window (Окно / Окно процесса моделирования / Окно

«Выражения»). Замените текущее значение в поле «Label» («Метка») диалогового окна на Номер звонка. А в поле «Expression» («Выражение») - на XN1. Нажмите View (Просмотр) и Memorize (Запомнить).

Прежде чем открыть это окно, нам необходимо восстановить все сохраненные выражения, которые были введены, когда мы открывали окно в первый раз. Выберите каждое выражение и нажмите View (Просмотр).

Наконец, когда все выражения будут восстановлены, нажмите ОК.

Теперь удалим транзакты и сбросим собранную статистику. Из главного меню выберите Command / CLEAR (Команда / CLEAR), затем выберите Command / Custom... (Команда / Ввести...) и наберите rmult 1.

Мы сбрасываем генератор случайных чисел номер 1, так как команда CLEAR этого не делает. Это необходимо, если вы хотите обеспечить

(23)

23

исходную точку потока. Таким образом, даже если вы использовали другие команды, не перечисленные в пособии, то после использования команды CLEAR мы будем видеть в течение этого процесса моделирования одни и те же результаты. В окне «Blocks» («Блоки») наведите указатель мыши на последний блок в модели (блок TRANSFER). Щелкните на значке блока TRANSFER и на значке «Place» («Поместить»).

Далее расположите окна «Blocks» («Блоки»), «Journal» («Журнал») и

«Expression» («Выражения») так, чтобы они все были видны. Выберите Command / START (Команда / START). В диалоговом окне замените 1 на 1000, NP и нажмите ОК.

Процесс моделирования останавливается при первой попытке транзакта войти в блок TRANSFER. Это указывает на то, что данный звонящий не может дозвониться. Продолжим выполнение процесса моделирования.

Нажмите [F2]. Выполните данную операцию еще 4 раза, каждый раз процесс моделирования будет приостанавливаться из-за условия остановки.

Процесс моделирования будет продолжать останавливаться каждый раз, когда звонящий должен ждать. Вы увидите трассировочные сообщения в окне

«Journal» («Журнал»), которые показывают номера приостановленных транзактов. Так как в этой модели имеется только один блок GENERATE, то по номеру транзакта вы можете видеть, как часто звонящие должны ждать и имеются ли звонящие, ждущие второй раз.

Теперь удалим условие остановки. В окне «Blocks» («Блоки») щелкните на значке блока TRANSFER и нажмите кнопку «Remove» («Удалить»). Затем закройте окна «В1оскs»(«Блоки») и «Expression» («Выражения»).

Теперь мы будем наблюдать за выполнением процесса моделирования с помощью окна «Storages» («Памяти») в режиме общего обзора. Из главного меню выберите Window/Simulation Window / Storages Window (Окно / Окно процесса моделирования / Окно «Памяти»), затем, чтобы отключить подробный обзор, выберите View / Entity Details (Вид / Подробности).

Теперь посмотрим, как строится диаграмма задержки звонков. Выберите Window / Simulation Window / Table Window (Окно / Окно процесса моделирования / Окно «Таблица»). В данном случае имеется только одна таблица, поэтому ее имя уже находится в выпадающем списке. Нажмите ОК.

Продолжим выполнение процесса моделирования. Нажмите [F2].

Таблица с именем Transit фактически является динамической диаграммой, которая может быть просмотрена в любое время. Она показывает, что большинство людей не обслуживается сразу же. Очевидно, что люди, обнаруживающие, что линии заняты, рады не будут. Когда закончите просмотр, закройте окна «Table» («Таблицы») и «Storages»

(«Памяти») и позвольте процессу моделирования завершиться.

Что если мы увеличим количество линий? Давайте промоделируем четыре линии вместо двух.

Прежде чем переопределить объект, необходимо использовать команду CLEAR. Выберите Command/ CLEAR (Команда / CLEAR), затем выберите

(24)

24

Command / Custom... (Команда/Ввести...). В диалоговом окне наберите Sets Storage 4 и нажмите [Enter], в следующей строке наберите rmult 1.

Нажмите ОК.

Таким способом переопределяется количество телефонных линий. Вы можете сделать это при любом открытом окне. Данное действие будет записано в окно «Journal» («Журнал») для последующего просмотра, если, конечно, вы оставили его открытым.

Давайте посмотрим, что произойдет. Выберите Command / START (Команда / START). В диалоговом окне замените 1 на 1000, NP и нажмите ОК.

Коэффициент использования телефонных линий стал намного меньше.

Посмотрим диаграмму длительности звонков. Выберите Window / Simulation Window / Table Window (Окно / Окно процесса моделирования / Окно

«Таблица»). Так как мы имеем только одну таблицу, то ее имя уже выбрано в выпадающем списке. Нажмите ОК.

В окне «Blocks» («Блоки») при подробном обзоре видно, что входов в блок TRANSFER не было, а это означает, что не было ни одного повторного звонка. Четыре линии намного лучше, чем две.

Изменим число линий на 3 и сравним результаты. Выберите Command / CLEAR (Команда / CLEAR), затем выберите Command / Custom... (Команда / Ввести...). Далее в диалоговом окне наберите Sets Storage 3.

Таким образом, мы изменим количество телефонных линий на 3.

Нажмите [Enter]. В следующей строке наберите rmult 1 и нажмите ОК.

Давайте посмотрим, что произойдет. Выберите Command / START (Команда / START). В диалоговом окне наберите 1000 и нажмите ОК.

Возможно, вы захотите открыть окно «Blocks» («Блоки»). Похоже, что три телефонные линии оказываются вполне эффективными. Быстрое изучение отчета показывает, что только 57 звонящих были вынуждены перезвонить.

Введите в базовую модель свои параметры, повторите все предложенные действия, скопируйте полученный отчет о моделировании в текстовый редактор, получите необходимые гистограммы, сделайте анализ результатам вашей работы, оформите отчет.

4.7 Контрольные вопросы

1. Какие объекты аппаратной категории GPSS используются при моделировании телефонной сети, содержащей «n» линий, одну линию?

2. Какие блоки необходимы при моделировании работы многоканального устройства?

3. В каком режиме работает блок TRANSFER в программе?

4. Сколько линий должна содержать исследуемая сеть, чтобы обеспечить требуемое качество обслуживания и быть экономически целесообразной?

5. Для чего предназначено окно «Expression» (Выражения)?

(25)

25

5 Лабораторная работа №5. Исследование на имитационной модели частной телефонной станции

Цель работы: анализ модели работы частной АТС и приобретение навыков использования динамических окон системы GPSS World для оптимизации функционирования системы для заданной нагрузки.

5.1 Подготовка к работе

5.1.1 Изучить пункты главного меню системы GPSS World, необходимые в работе: меню: Window/Simulation, Window/Table/Storage/Expression/.

5.1.2 Изучить блоки и команды необходимые в модели 5.2 Задание к работе

Изучить базовую модель простой АТС, освоить работу с базовой моделью, используя динамические окна. Внести изменения в базовую модель соответственно вашему варианту. Провести процесс моделирования, получить результаты и сделать анализ и выводы.

5.3 Порядок выполнения работы

5.3.1 Определить коэффициент использования оператора, сигнализаторов, внутренних и внешних линий, параллельных телефонов.

5.3.2 Определить количество внутренних и внешних звонков, обрабатываемых каждую минуту.

5.3.3 Определить, достаточно ли внутренних и внешних линий, сигнализаторов.

5.3.4 Получить результат моделирования в виде отчета, гистограмм и оперативного экрана.

5.3.5 Подготовить отчет о выполненной работе, где представить свою модель, результаты моделирования и сделать выводы.

5.4 Варианты заданий Т а б л и ц а 5.1

варианта

Число

параллельных телефонов

Число внутренних линий

Число внешних линий

Число

сигнализато- ров

1 100 20 31 5

2 105 21 30 6

3 115 22 29 7

4 120 23 28 8

(26)

26 Окончание таблицы 5.1.

5 125 24 27 9

6 130 25 26 4

7 135 26 25 5

8 140 27 24 6

9 145 28 23 7

10 150 29 22 8

11 155 30 21 9

12 160 31 20 5

13 165 32 25 6

14 170 33 26 7

15 175 34 27 8

5.5 Методические указания к выполнению лабораторной работы

На частном узле телефонной связи имеются 200 параллельных телефонов, 30 внутренних линий, 30 внешних линий, 8 сигнализаторов и 1 оператор. В среднем телефонные звонки длятся 150 секунд и распределены по нормальному закону со стандартным отклонением в 30 секунд. Время между поступлением внешних звонков обратно пропорционально количеству параллельных телефонов (2500 разделить на количество параллельных телефонов) и распределено по экспоненциальному закону. Время между поступлением внутренних звонков обратно пропорционально количеству свободных параллельных телефонов (1260 разделить на количество свободных параллельных телефонов плюс 1). Направление этих звонков может быть внутренним (66.6%) и внешним (33,3%). Для звонков, поступающих с внутренних телефонов, оператор не нужен. Для внутренних звонков требуется сигнализатор и внутренняя линия, для внешних звонков - внешняя линия.

При звонке 15% параллельных телефонов занято, 20% - не отвечают.

Время, требуемое для сигнализации, равно 7±2 секунд, для звонка через параллельный телефон - 6±2 секунд. Звонящий слушает сигнал «занято» 4+1 секунду. Работа оператора занимает 9±3 секунды.

Необходимо смоделировать работу частного узла телефонной связи в течение 1 часа, а также:

1) Определить коэффициент использования оператора, сигнализаторов, внутренних и внешних линий, параллельных телефонов.

2) Определить количество внутренних и внешних звонков, обрабатываемых каждую минуту.

3) Определить, достаточно ли внутренних и внешних линий, сигнализаторов.

Ниже представлен листинг базовой модели.

(27)

27

* Модель частной телефонной системы

* Время в секундах

*******************************************************************

Transit TABLE Ml,20,20,20

*******************************************************************

Extensions STORAGE 200 Extlines STORAGE 30 Intlines STORAGE 30 Signals STORAGE 8 Operator STORAGE 1

*******************************************************************

* Определение переменных

Internal VARIABLE 1260/(l+R$Extensions)

External VARIABLE 2500/(R$Extensions+S$Extensions)

*

* Таблицы количества звонков

Callsint TABLE S$Intlines,2,2,20 Callsext TABLE S$Extlines,2,2,20

*******************************************************************

* Генерируются звонки, поступающие с внутренних телефонов.

GENERATE (Exponential (1,0 ,V$Internal)), 0 ,20 ;Вн. звонки.

ENTER Extensions ;Снята трубка телефона.

QUEUE Inside ;Очередь на сигнализатор.

ENTER Signals ;Занимается сигнализатор.

DEPART Inside ;Выход из очереди.

ADVANCE 7,2 ;Время для сигнализации.

LEAVE Signals ;Сигнализатор освобождается.

TRANSFER .333,,Intout ;44% звонков на внешние линии.

Intint TEST GE R$Intlines,1,Breakoff ;Проверка доступности.

ENTER Intlines ;Занимается внутренняя линия.

ADVANCE 4,1 ;Проводится проверка, занят ли телефон.

TRANSFER .15,,Busy ;Некоторые парал. телефоны заняты.

Aline ENTER Extensions ;Другие не заняты.

ADVANCE 6,2 ;Время для звонка по парал. телефону.

TRANSFER .2,,Nogood ;20% не отвечают.

ADVANCE (Normal (2,150,30)) ;Продолжительность звонка.

Nogood LEAVE Extension ;Парал. телефон освобождается.

Busy LEAVE Intlines ;Внутренняя линия освобождается.

TRANSFER ,Breakoff

* Модель звонков с внутренних телефонов на внешние линии.

Intout TEST GE R$Extlines, 1 ,Breakoff ;Доступна ли внешняя линия?

ENTER Extlines ;Занимается внешняя линия.

ADVANCE 4,1 ;Время для проверки на занятость.

TRANSFER .200,,Nobody ;20% заняты.

Ақпарат көздері

СӘЙКЕС КЕЛЕТІН ҚҰЖАТТАР

На базе STEAM-технологии была проведена исследовательская работа на тему «Исследование зависимости силы трения скольжения от силы нормального давления».. Цель

Цель данной работы — исследование влияния гумата натрия и поливинилового спирта на струк- турообразование крахмала и выявление наличия интерполимерных

Цель работы: п роверить буфер клавиатуры на наличие в нём символов, а также получить состояние переключающих клавиш,

Данное исследование является анализом современных публикаций, посвященных улучшению и оптимизации работы системы теплоснабжения районов города на основе

Цель работы: создания и редактирования текстовых файлов конфигурации безопасности операционной системы Windows 2003

Цель работы – исследование влияния го- рючих сланцев на структурные преобразования при термообработке шихт для получения пори- стых

Цель работы – исследование влияния способа приготовления формовочной массы на свойства магнезиальных композиций различного состава и структуры.. Объектом

Цель работы: Оценка положительных и отрицательных факторов использования методик дистанционного обучения педиатров на примере Алтайского